Animation playback gets glitchy at high frame rates

  • updated
  • Not a bug
  1. Before 1.4.2, I had no issues with playback on 1080p 24fps animations. But recently, whenever I play an animation at high frame rates like this, some of the frames tend to jump to different positions in playback.

I have a 2019 iPad Air running the latest iPadOS, with FlipaClip at version 1.4.5. I hope you can help!

Pinned replies
Jona
  • PINNED
  • Started

Hey thanks for the feedback! So what is laggy the animation playback preview? If that is the case let me explain what's going on. :)

So FlipaClip caches most frequently used frames into memory for really fast access. However, when we reach a limit on the amount of memory that can be used things do get a little slower. The reason is that reading an image from file takes time. So the more layers you have the longer a frame will take to load. So when you have a lot of frames they can't all be cached so live previewing slows down.

We have done miracles with speed in this area and we aren't stopping there. We are currently working on new methods to further improve the app speed for this area.

So with that in mind. We limit the number of layers for now since more layers means slower app performance. But this is something we are working on and will add more layers in the near future.

In the meantime, you can try to play the animation at a lower FPS, that should resolve your problem for now. Also, try to disable canvas rotation and remove FlipaClip from battery optimization because not enough RAM on your device can cause this issue.

Jona
  • Planned
Hey, thanks for your feedback. Unfortunately on some devices live previewing of a project can be a bit slow causing some frames to be dropped during playback. We know there are some areas we can improve here and will be doing so very soon. So we will provide an option to lower the canvas size allowing huge speed improvements.
Patrick Hawkey
If you have 2 or 3 layers enabled, you can disable the backround layers and just concentrate on the animation layer, this speeds things up a bit.

Exporting to movie, it'll Play at the correct Speed.


Jona
Quote from Patrick Hawkey
If you have 2 or 3 layers enabled, you can disable the backround layers and just concentrate on the animation layer, this speeds things up a bit.

Exporting to movie, it'll Play at the correct Speed.


Thanks for the feedback. You are right disabling the bg would speed up things a bit more. At the moment the bottle neck for us is actually loading the frame layers. Blending the layers isn't really an issue, it's just the file loading process. However, we are already experimenting and trying different things to double up on speed if possible.
Jona
  • PINNED
  • Started

Hey thanks for the feedback! So what is laggy the animation playback preview? If that is the case let me explain what's going on. :)

So FlipaClip caches most frequently used frames into memory for really fast access. However, when we reach a limit on the amount of memory that can be used things do get a little slower. The reason is that reading an image from file takes time. So the more layers you have the longer a frame will take to load. So when you have a lot of frames they can't all be cached so live previewing slows down.

We have done miracles with speed in this area and we aren't stopping there. We are currently working on new methods to further improve the app speed for this area.

So with that in mind. We limit the number of layers for now since more layers means slower app performance. But this is something we are working on and will add more layers in the near future.

In the meantime, you can try to play the animation at a lower FPS, that should resolve your problem for now. Also, try to disable canvas rotation and remove FlipaClip from battery optimization because not enough RAM on your device can cause this issue.

Jona
  • Not a bug

There are two types of movie playback preview you can do. One, swipe on the frames timeline and second pressing the movie preview button. These two different playback options behave differently.


Swipe preview will drop frames along the way if the swipe is really fast. The play preview button option will not drop any frames. It will play them as fast as possible to match the projects FPS setting. In some cases the preview FPS will be slower because loading frames would be loaded from file and not the frames cache.


As I mentioned on this post we are looking at ways to improve the speed which frames are loaded and shown to minimize movie playback slowness and frame drop. For the reason I explained this is not a bug.

Jona
  • Not a bug

Hey, thanks for providing your feedback about this particular area.


When the FPS value is lower than the value set under the project settings it means the frame images are not loading fast enough. The main reason is that reading images from file takes a little while, and some devices are faster at this than others. Also, the more layers you have for a frame it means the more images it needs to load.


Because of this issue we are developing a new method to deal with frame image loading that on some devices will more than double the current loading speeds. We are shooting for the next update to add this feature. ;)

Jona
  • Completed

More information about common issues with live animation playback.

http://support.flipaclip.us/topics/707-live-video-playback-common-issues/

Snes Bro (Robert s.)

I just want to know what I can do to fix this + if it will affect my animation while editing it.

Cosmic Peachez

THIS KEEPS HAPPENING TO ME TOO!!!!!! I THOUGHT I HAD DONE SOMETHIGN WRONG

Koala

it happens after I updated iOS 12